Announcement

Collapse

Forum Etiquette - Please Read Before Posting

Please read the forum etiquette, by posting here you agree to be part of a polite society. https://vb.ourunraveled.com/articles...rum-ettiquette
See more
See less

Links not working, trouble deleting links

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Links not working, trouble deleting links

    Admin - I've had this problem come up a couple of times: I add a link to a post. I post it and try the link to make sure it works. The link doesn't work so I try a few times to copy and paste the link but it doesn't direct to the right page. Then I try to delete the link completely from my post but I keep getting the message that I need to add a URL. I tried multiple times to delete the link but kept getting the same message. I gave up and just edited the post adding a message to ignore the bad link.
    Naperville, IL - Growing Zone 5

    #2
    lovestostitch A related issue, but I've had issues adding links to posts as well and I've seen others also have the same problem. A copied and pasted URL should automatically hyperlink when added to a post, but that isn't happening some of the time. It works when using the linking tool, but that shouldn't be necessary. I have not had a problem with the URL's not working when copied from my posts, but one shouldn't need to copy and paste the link to get to another site.

    Comment


      #3
      Would you be able to post examples of working ones vs. not working ones? It might be a setting I have wrong but the ones I've tried seem to work so it's hard for me to reproduce.
      “The only thing necessary for the triumph of evil is for good men to do nothing." -- Edmund Burke

      Comment


        #4
        Admin - here is the link I tried to do this morning. I went to the website, copied the address, hit the link button here and pasted it. I'll post it and see if it works and then I'll try to delete it like I did this morning.

        I tried to remove the link by going to edit and then clicking on "remove link." Then I hit Save and I get an error message that says: Please enter a valid URL. I can not save the edited post. My only option was to cancel the edit. It will allow me to edit the text but not remove the link.
        Last edited by lovestostitch; 08-07-2019, 05:19 PM.
        Naperville, IL - Growing Zone 5

        Comment


          #5
          Admin - so the one above doesn't work. I'm going to try a different website link.

          ETA: this one works.
          Naperville, IL - Growing Zone 5

          Comment


            #6
            Sorry for all the questions, what do you mean by "Doesn't work" ? Do you mean it's not a link and can't be clicked, or like it doesn't go where you think it should go?

            Not trying to be obtuse just trying to understand what's going on.

            When I go to the top one, it takes me to the exact URL that's posted, which returns an NGINX page, that seems to be a misconfiguration on knittingparadise from what I can tell.

            The second two in your second post seem to go to where they point and are successful.
            “The only thing necessary for the triumph of evil is for good men to do nothing." -- Edmund Burke

            Comment


            • lovestostitch
              lovestostitch commented
              Editing a comment
              Yes, by "doesn't work," I meant the link didn't take me to the page I was trying for. I realize that this could have been Knitter's Paradise's problem. The problem with Our Unraveled is that it would not allow me to delete the link from my post and then repost. This has happened to me before.

            #7
            Admin - tried to link another website to give someone a pattern and it wouldn't work. I tried copying the URL and pasting it into the link address bar. After posting it, I tried it and it didn't go to the pattern page. Then I tried emailing myself the link. I tried the link from my email and it took me to the pattern page. So I copied the URL from my email and pasted it in the link address bar. After posting, I tried it and it took me to the main page of the website, not the pattern page. If it works from my email, I don't see how it can be the website misdirecting.

            I again tried deleting the link and it wouldn't let me save the post without adding a new link.

            Here is the link I tried to post.
            Naperville, IL - Growing Zone 5

            Comment


            • Admin
              Admin commented
              Editing a comment
              Gotcha, ok I'm seeing it messed up now, I'll see if I can get it figured out.

            • Admin
              Admin commented
              Editing a comment
              Ok, I think I know what's going on with some of them, when you see a clickable link on a website or e-mail there are 2 pieces to it, the actual link, and the "name" of that link, it looks like when you paste a link that has both pieces it's not picking it up right.

              the code would look like this: <a href="
              https://static.knittingparadise.com/upload/2012/10/29/1351524004286-perfect_fit_dog_sweater_pattern.pdf">Link to KP</a>

              I think what's happening is it's just picking up the "name" part for some reason and not the link part.

            #8
            Test Post:


            https://static.knittingparadise.com/...er_pattern.pdf

            https://static.knittingparadise.com/...er_pattern.pdf

            Comment


              #9
              Test 2

              Comment


                #10
                Ok, I figured out why some work and some don't and I think I figured out how to remove links.

                The link I pasted into the text field seemed to work, and the one I added from the little "chain link" icon worked.

                Click image for larger version

Name:	Screenshot from 2019-08-08 06-57-16.png
Views:	40
Size:	39.2 KB
ID:	16732

                Click image for larger version

Name:	Screenshot from 2019-08-08 07-02-01.png
Views:	30
Size:	6.9 KB
ID:	16733


                The one I added from the link button in the top left did the same thing yours did.

                Click image for larger version

Name:	Screenshot from 2019-08-08 06-59-54.png
Views:	31
Size:	4.9 KB
ID:	16734


                When I added the link this way, it showed up underneath the text box where I could edit or remove it afterward, this is how yours shows (the broken one).

                Click image for larger version

Name:	Screenshot from 2019-08-08 06-58-26.png
Views:	31
Size:	75.9 KB
ID:	16735
                “The only thing necessary for the triumph of evil is for good men to do nothing." -- Edmund Burke

                Comment


                • lovestostitch
                  lovestostitch commented
                  Editing a comment
                  I did use the chain in the upper left. I'll have to try it the other way.

                  I just tried adding the link directly into the text box and it was successful but it would not let me delete the bad link.
                  Last edited by lovestostitch; 08-08-2019, 09:44 AM.

                #11
                lovestostitch are you using phone or desk/lap top browser?
                Everyone is entitled to their own opinions, but not their own facts
                =====
                My personal views & Opinions may well not be those of the owners, management and other moderators - nor, are they intended to be personal, but may require adult sized undies.

                Comment


                #12
                okay - the only thing I can say is that different browser do some things that cause link problems if you just cut & paste
                take a close look as a facebook link sometime - enough tracking crap to make one's head spin.

                hopefully Admin will be able to see where it is going wrong

                But for that link specifically, it is the "static" that precedes knittingparadise.com that is causing the problem.
                I am guessing it was cut and paste from some sort of favorites list,
                and short of testing and editing prior to posting, now sure what you can do.

                sorry not be more helpful
                Everyone is entitled to their own opinions, but not their own facts
                =====
                My personal views & Opinions may well not be those of the owners, management and other moderators - nor, are they intended to be personal, but may require adult sized undies.

                Comment


                • lovestostitch
                  lovestostitch commented
                  Editing a comment
                  I am not a techie at all but if I can copy and paste the URL into the text box successfully but pasting it into the "add link" box doesn't work, it seems that the problem is with the add link box. Besides that, the add link feature is problematic because it won't allow you to delete your link. I'm glad I'm just a happy user. I totally appreciate all the work Admin is doing to get everything working.

                #13
                I get this message a lot when I am browsing links within OUR. I am of course logged in...

                Click image for larger version

Name:	C23A1660-60FE-4B63-9520-2188BB82DE98.jpeg
Views:	46
Size:	102.2 KB
ID:	16867
                Knitting is happening here! ❤️

                Comment


                  #14
                  wheat I agree that the "static" might be what is causing trouble. Another thought, for security reasons I wonder if the site administrators have disabled links included in posts that are direct downloads. I don't know if there is a setting for that on the platform or not. If so, that could also be causing the behavior. I noticed that particular link is directly to a PDF which would trigger a file to auto-open either in browser or in a PDF reader. Even PDF's, which are thought of as more secure by many people, can contain malware. I generally won't click a link to a direct download like that - one that is included in a post. (I will hover over the link to see what the extension is or where it leads before clicking.) I'd rather be directed to the site where the file resides and make my own decision about whether to open it.

                  Comment


                    #15
                    I have a theory about the logged in message based on something else I am trying to understand - this may take awhile but I am suspecting it has to do with blogs & some groups require you to have joined vs the forums which are mostly open. Too much of new versions of software to wrap my head around at o be time.
                    Everyone is entitled to their own opinions, but not their own facts
                    =====
                    My personal views & Opinions may well not be those of the owners, management and other moderators - nor, are they intended to be personal, but may require adult sized undies.

                    Comment

                    Working...
                    X